[BITTE LOGBUCH] Unmotivierter Alarm in der Ladestation

- alle Auffälligkeiten, die es zu klären gilt
- Verdacht, dass ein echter Bug vorliegt
zwiebelmaett
Forum-Nutzer
Beiträge: 18
Registriert: Mo 23. Apr 2018, 20:53
Mäher: Husqvarna Automower 330X
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2014
Robonect Firmware: 1.0beta5

[BITTE LOGBUCH] Unmotivierter Alarm in der Ladestation

Beitrag von zwiebelmaett »

Soeben hat mein Mäher laut aufgeheult und einfach so den Diebstahl-Alarm aktiviert.
Die zugehörige Alarmmeldung lautete: "Mäher gestoppt"
Der Mäher stand aber in seiner Mähergarage in der Ladestation. Da hat niemand dran gewackelt oder sowas.

Durch Zufall habe ich kurz vorher noch ein Doppelpiep gehört wie bei der Abfrage bestimmter Daten über die API.
Ich nutze die FHEM-Integration, die alle 90 Sek. Status und Health abfragt, aber normalerweise kein Piepen verursacht.
Der Mäher heute Nachmittag manuell am Display durch die Option bis morgen zu parken in die Station geschickt worden.

Benutzeravatar
shadowkiller
Forum-Veteran
Beiträge: 3189
Registriert: Do 11. Jan 2018, 08:42
Wohnort: Würzburg
Mäher: Husqvarna Automower 315
Firmware des Mähers (MSW): MSW 10.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: 1.2 (Daily Build, WLAN 1.7.4)
hat sich bedankt: 1 Mal
wurde gedankt: 4 Male

Re: Unmotivierter Alarm in der Ladestation

Beitrag von shadowkiller »

hmm,

laut aufheulen - war es ein normaler Alarmton (das wäre kein Aufheulen, richtig?), oder klang es "komisch"?

die 1.0 Beta 4 setzt Robonect sehr schnell in den Schlafmodus, nachdem man was abfragt und piepst bei jedem aufwecken, um diese Daten abzufragen. Teste mal ein längeres Intervall, ob das mit dem Piepen kongruiert.

Und auch wie bei Deinem Klingenwechsel-Fehlalarm:

- Entwicklermodus an, oder war mal an?
- Robonect schon neu gestartet?
Robonect® Dokumentation und Support
--
Forum cooler nutzen: Hervorhebungen machen und Screenshots posten
--
Es wurde schon alles gefragt, nur noch nicht von allen. (frei nach Karl Valentin)

Admin
Administrator
Beiträge: 2764
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena SILENO City 500
Firmware des Mähers (MSW): MSW 11.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: stets die Allerneuste :-)
hat sich bedankt: 1 Mal
wurde gedankt: 2 Male
Kontaktdaten:

Re: [BITTE LOGBUCH] Unmotivierter Alarm in der Ladestation

Beitrag von Admin »

Moin, schicke mir mal bitte das Logbuch zusammen mit Datum und Uhrzeit des Ereignisses. Ich sage Dir dann, was da los war.
Werbefläche zu vermieten. :lol:

zwiebelmaett
Forum-Nutzer
Beiträge: 18
Registriert: Mo 23. Apr 2018, 20:53
Mäher: Husqvarna Automower 330X
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2014
Robonect Firmware: 1.0beta5

Re: [BITTE LOGBUCH] Unmotivierter Alarm in der Ladestation

Beitrag von zwiebelmaett »

Logbuch ist per PM raus.

Es war der normale Alarmton, der auch losgeht, wenn jemand die Stopp-Taste drückt, dann aber nicht rechtzeitig die richtige PIN eingibt. Ich nehme mal an, dass der Mäher der Meinung war, dass sowas passiert wäre.

Der Entwicklermodus ist und war niemals eingeschaltet.

Admin
Administrator
Beiträge: 2764
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena SILENO City 500
Firmware des Mähers (MSW): MSW 11.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: stets die Allerneuste :-)
hat sich bedankt: 1 Mal
wurde gedankt: 2 Male
Kontaktdaten:

Re: [BITTE LOGBUCH] Unmotivierter Alarm in der Ladestation

Beitrag von Admin »

Danke für das Logbuch. Es ist voll von Tränen und schmerzhaften Schreien. Denn du peitscht Robonect ständig aus.

Du schreibst, dass du alle 90 Sekunden Status und Health abfragst, was ok ist.

Aber irgendwas oder jemand fragt alle 2 Sekunden noch etwas anderes ab und wartet nicht auf die Antwort, sondern schickt gleich die nächste Anfrage hinterher.
Dadurch werden sehr viele Daten verworfen etc.
Hast du eine Ahnung, wer oder was das macht?
Werbefläche zu vermieten. :lol:

Admin
Administrator
Beiträge: 2764
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena SILENO City 500
Firmware des Mähers (MSW): MSW 11.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: stets die Allerneuste :-)
hat sich bedankt: 1 Mal
wurde gedankt: 2 Male
Kontaktdaten:

Re: [BITTE LOGBUCH] Unmotivierter Alarm in der Ladestation

Beitrag von Admin »

Nachtrag:
Es handelt sich um eine Abfrage auf die Betriebsstunden. Also vermutlich cmd=hours. Und ob die Abfrage im 2 Sekunden Takt kommt oder noch schneller kann ich nicht sagen.

Ich sehe auch, dass teilweise 5 Abfragen gleichzeitig aktiv sind, ich nehme also an, du pollst noch viel schneller.

Was aber auch auffällig ist: Nach ca. 22:02 hören diese Zugriffe auf. Evtl. kam es hier innerhalb FHEM zu einet Deathloop, weil eine Anfrage nicht rechtzeitig beantwortet wurde, woraufhin eine neue abgesendet wurde und es irgendwie zu einem Lawineneffekt kam...
Werbefläche zu vermieten. :lol:

zwiebelmaett
Forum-Nutzer
Beiträge: 18
Registriert: Mo 23. Apr 2018, 20:53
Mäher: Husqvarna Automower 330X
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2014
Robonect Firmware: 1.0beta5

Re: [BITTE LOGBUCH] Unmotivierter Alarm in der Ladestation

Beitrag von zwiebelmaett »

Also, nachdem ich den Alarm abgeschaltet hatte, habe ich mich über den Browser auf das Webinterface verbunden, um selbst zu sehen, was da wohl los war.
Dabei habe ich sicherlich auch die Betriebsstunden abgefragt, was zumindest beim ersten Aufruf auch nach mehr als 30 Sekunden keine Antwort geliefert hatte. Ob ich danach noch mal auf die Stunden geklickt hatte oder auf was anderes weiß ich jetzt nicht mehr. Ob das Webinterface aber möglicherweise von sich aus mehrfach pollt kann ich natürlich auch nicht sagen.
Es kann auch sein, dass sich meine manuelle Anfrage da einmal mit der zyklischen Anfrage des FHEM-Servers überschnitten hatte.
Normalerweise lass ich den Mäher ja in Ruhe mähen und schauen mir abends gelegentlich mal die Logs in FHEM oder den Status im Webinterface an. Wenn da tatsächlich regelmäßig so viele Anfragen gleichzeitig kämen, dann müsste ich noch mal genauer analysieren, wie das passiert.

Admin
Administrator
Beiträge: 2764
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena SILENO City 500
Firmware des Mähers (MSW): MSW 11.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: stets die Allerneuste :-)
hat sich bedankt: 1 Mal
wurde gedankt: 2 Male
Kontaktdaten:

Re: [BITTE LOGBUCH] Unmotivierter Alarm in der Ladestation

Beitrag von Admin »

Das Logbuch wurde leider nicht vollständig runtergeladen, da scheinbar beim Download die Verbindung abgebrochen ist, deshalb weiss ich nicht mehr, wann es losgeht. Um 21:30 war der Terror aber schon aktiv.
Werbefläche zu vermieten. :lol:

zwiebelmaett
Forum-Nutzer
Beiträge: 18
Registriert: Mo 23. Apr 2018, 20:53
Mäher: Husqvarna Automower 330X
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2014
Robonect Firmware: 1.0beta5

Re: [BITTE LOGBUCH] Unmotivierter Alarm in der Ladestation

Beitrag von zwiebelmaett »

Habe ich denn eine Chance, selbst herauszufinden, was den Terror verursacht, indem ich selbst das Logbuch verstehe?
Im XML sehe ich ja schön <time> Tags im Zwei-Sekunden-Rhythmus, aber was event-id und data bedeuten ist mir ein Rätsel...

zwiebelmaett
Forum-Nutzer
Beiträge: 18
Registriert: Mo 23. Apr 2018, 20:53
Mäher: Husqvarna Automower 330X
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2014
Robonect Firmware: 1.0beta5

Re: [BITTE LOGBUCH] Unmotivierter Alarm in der Ladestation

Beitrag von zwiebelmaett »

Ich habe gerade noch mal ein Logbuch heruntergeladen, das ist aber 2,1 MB groß und darf nicht an eine PN angehängt werden. :roll:

Gesperrt

Zurück zu „Bug?“