. :daumenhoch: Erstinstallation für Neueinsteiger: Bitte hier entlang!

. :daumenhoch: Robonect-Gebrauchsanweisung und Support für alle Robonect-Menüpunkte! Bitte hier entlang!

. :arrow: Für jeden Robonect-Menüpunkt gibt es dort ein eigenes Unterforum
. :arrow: Erklärung des Menüpunkts und unser Support direkt dort im Unterforum des Menüpunkts!

Better connection?

Stelle Deine Frage passend zum folgenden Robonect-Menüpunkt:
Access-Point (<- anklicken!)
Heimnetz (<- anklicken!)
Fernzugriff (<- anklicken!)
allgemeine Frage (<- anklicken!)

Erkläre Dein Problem zusätzlich mithilfe eines Screenshots Deiner Einstellungen:
Anleitung zum Erstellen und Posten von Screenshots (<- anklicken!)

Schnellhilfe - beantworte diese Fragen bitte in Deinem Beitrag hier im Forum!

Regeln:
  • Du hast ein ähnliches oder dasselbe Problem wie jemand anderes?
  • Du hast keine Erklärung in der Dokumentation gefunden?
    :arrow: Eröffne bitte ein neues Thema, da jeder Fall andere Ursachen haben kann!
  • Beantworte darin die folgenden Fragen:
    1. Ist bereits die aktuelle Firmware installiert?
    2. Ist bereits der neueste WLAN-Treiber installiert? Du findest ihn zusammen mit wichtigen Hinweisen unter "aktuelle Firmware".
    3. Erfüllt Dein Heimnetz unseren Gold-Standard für die Robonect-Einbindung ins Heimnetz?
      • Wenn nein - und sei es zumindest vorübergehend zur Fehlersuche, ist leider kein Support möglich.
        -> Stelle Dein Heimnetz zunächst komplett mit allen Geräten auf den Gold-Standard um, um zu sehen, ob das Problem dadurch behoben wird.
      • Wenn Du Dein Heimnetz auf den Gold-Standard umgestellt hast und der Fehler weiterhin auftritt, beschreibe diesen bitte aussagekräftig.
      Frage Dich zusätzlich:
    4. Nutze ich (unbewusst) mehr, als die technisch maximal möglichen 5 Verbindungen zu Robonect gleichzeitig? Z.B. Visualisierung, App, Zugriff über Webseite, Fernzugriff, DynDNS, MQTT, etc ... auf mehreren Geräten verteilt?
    5. Besitzt meine Ladestation eine Garage/Hütte/Unterstand? Welches Material hat diese?
    6. Habe ich einen Pool oder ein Regenreservoir in der Nähe des Routers/APs oder der Ladestation?
    7. Habe ich auch mit Kanal 1 und Kanal 12 (manuelle Einstellung im Router und allen APs!) immer noch Probleme?
    8. Zeigt Robonect im Webinterface beim WLAN-Symbol mindestens den ersten Bogen?
Antworten
heinowalther
Forum-Anfänger
Beiträge: 3
Registriert: Mo 29. Apr 2019, 14:22
Mäher: Husqvarna Automower 315
Robonect Firmware: 1.0B7a

Better connection?

Beitrag von heinowalther »

Hi there

I hope English is OK here? I can read German, but it would take me too long to write this in German :-)
about the questions above:
1: Ja (UNIFI Based network with five APs)
2: Nein (The mower pulls the weather and pushes MQTT Status)
3: Nein (the mower is placed up against the house (brick) on the lawn)
4: Nein
5: Ja
6: Ja

My mower is an Automower 315 and I installed the Robonect module 3 years ago.
I am of cause on the latest released firmwares (not betas)
It has been working on and off, and now I would like to teak it a bit.
As the mower is mowing, it gets past 3 or 4 APs, but much like an iPhone it seems to keep its connection to the AP even if the quality is lower than the AP right next to it... even if I press "reconnect" from the UNIFI GUI, which normally forces the client to reconsider the APs and choose the one with the best quality connection.
I think the Robonect module is a bit limited in this regards? Hence point 5 in your list... does the module only like to connect to the two channels 1 and 12 ? Because I must admit that some of my APs are using other channels, or else they would all use the same bandwidth??

I have the local AP enabled on the modul so that I can reach it with my laptop, but even with that, it struggles to connect and present me with a web-page. It manages eventually... this might be because as I connect my laptop, it will automatically try to route traffic via the gateway it has been given, which is the Robonect module, and it will therefore get some requests, and maybe this is the reason why it is slow to respond? So should I try to stop everything on my laptop before connecting?

Anyway, what I am getting at, is that... does it make sense to orientate the antenna differently in the mower? Maybe even drill a hole so that the antenna is not covered by the shell? and what it the optimal orientation? I think that right now the antenna is vertically installed on the PCB as I received it. But I think I have an Extension antenna that I could install externally... But have anyone else done this, and did it make any difference?

If everything else fails, I might try to setup a separate WLAN just for the mower, which uses channel 1 or 12, and that it can reach from the station. it will then be OUT of reach when mowing, but it is still better that now, where it cannot reach anything even when in the station, which causes it to not start mowing because it cannot get any weather data...
(maybe a feature that said... just start mowing even if we cannot get any weather data, would be nice?) ;-)

Anyway thanks for a great product.

(replies in German is OK with me)

/Heino

Lampi
sehr erfahrener Forum-Nutzer
Beiträge: 547
Registriert: Di 14. Feb 2017, 17:07
Mäher: Husqvarna Automower 330X
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2014
Robonect-Modul: Robonect Hx (Rev.1)
Robonect Firmware: V1.3
hat sich bedankt: 4 Male
wurde gedankt: 51 Male

Re: Better connection?

Beitrag von Lampi »

Hallo Heino,

entschuldige bitte die späte Antwort.
Auf Englisch zu schreiben ist absolut okay.


heinowalther hat geschrieben:
Do 3. Jun 2021, 15:36
I think the Robonect module is a bit limited in this regards? Hence point 5 in your list... does the module only like to connect to the two channels 1 and 12 ?
Robonect ist bedingt durch das verbaute Wlan Modul bei der Verbindung sehr träge. Erst wenn die Verbindung abgebrochen ist, wird eine neue Verbindung mit dem dann stärstem AP aufgebaut. Dabei spielt der verwendete Kanal vom AP keine Rolle. Grundsätzlich kann sich Robonect mit jedem Kanal verbinden, nur mit Kanal 13 hat es vereinzelt Probleme gegeben.


heinowalther hat geschrieben:
Do 3. Jun 2021, 15:36
So should I try to stop everything on my laptop before connecting?
Ist bestimmt einen Versuch Wert. Normalerweise sollte bei gutem Empfang die Webseite sich über den AP von Robonect recht schnell aufbauen. Das könnte aber auch vom verwendetem Betriebssystem und/oder Browser abhängig sein.


heinowalther hat geschrieben:
Do 3. Jun 2021, 15:36
does it make sense to orientate the antenna differently in the mower?
Die Antenne sollte möglichst senkrecht nach oben stehen. In diesem Beitrag wurde schon mal von einem Verlegen der Antenne nach außen berichtet.

heinowalther hat geschrieben:
Do 3. Jun 2021, 15:36
maybe a feature that said ... just start mowing even if we don't get any weather data would be nice?
Erstelle bitte unter Wünsche dafür ein neues Thema. Hier wird es keine Beachtung finden.


Gruß
Lampi
Fragen? Fragen!

Antworten

Zurück zu „Verbindungsprobleme?“